Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-45815

Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler

Description

Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache NimBLE

Default version status: unaffected

  • 0 to ≤ 1.9.0affected

References