Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-45205

Apache Commons Configuration: StackOverflowError for YAML input with cycles

Description

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Commons Configuration

Default version status: unaffected

  • 2.2 to < 2.15.0affected

References