Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2026-45133

Symfony: [Yaml] Harden the parser when handling untrusted input

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

symfony symfony

  • < 5.4.52affected
  • >= 6.0.0-BETA1, < 6.4.40affected
  • >= 7.0.0-BETA1, < 7.4.12affected
  • >= 8.0.0-BETA1, < 8.0.12affected

References