Description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
vercel next.js
>= 15.2.0, < 15.5.17affected>= 16.0.0, < 16.2.6affected
References
- https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6 ↗
- https://access.redhat.com/security/cve/CVE-2026-45109 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2477190 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45109.json ↗
- https://access.redhat.com/errata/RHSA-2026:40974 ↗
- https://access.redhat.com/errata/RHSA-2026:37272 ↗
- https://access.redhat.com/errata/RHSA-2026:34608 ↗
- https://access.redhat.com/errata/RHSA-2026:54435 ↗