Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2026-44981

CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression

Description

CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

crowdsecurity crowdsec

  • >= 1.7.0, < 1.7.8affected

References