Description
An LDAP injection vulnerability in the LDAP Certificate repository of the XKMS server in Apache CXF may allow an attacker to retrieve arbitrary certificates from the repository. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache CXF
Default version status: unaffected
4.2.0 to < 4.2.1affected4.0.0 to < 4.1.6affected0 to < 3.6.11affected
References
- https://lists.apache.org/thread/c1zqxppo1m5z3kbdhjn5p991zk09ynkh ↗
- http://www.openwall.com/lists/oss-security/2026/05/22/9 ↗
- https://access.redhat.com/security/cve/CVE-2026-44930 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2480728 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44930.json ↗
- https://access.redhat.com/errata/RHSA-2026:37390 ↗