Skip to content
CVE PROGRAM SOURCE RECORD2.3 Low

CVE-2026-44911

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

Description

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache NiFi

Default version status: unaffected

  • 1.15.0 to ≤ 2.9.0affected

References