Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2026-44580

Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input

Description

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

vercel next.js

  • >= 13.0.0, < 15.5.16affected
  • >= 16.0.0, < 16.2.5affected

References