Description
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
vercel next.js
>= 16.0.0, < 16.2.5affected>= 13.4.13, < 15.5.16affected
References
- https://github.com/vercel/next.js/security/advisories/GHSA-c4j6-fc7j-m34r ↗
- https://access.redhat.com/security/cve/CVE-2026-44578 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2477187 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44578.json ↗
- https://access.redhat.com/errata/RHSA-2026:40974 ↗
- https://access.redhat.com/errata/RHSA-2026:37272 ↗
- https://access.redhat.com/errata/RHSA-2026:34608 ↗
- https://access.redhat.com/errata/RHSA-2026:54435 ↗