Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
vercel next.js
>= 15.4.0, < 15.5.16affected>= 16.0.0, < 16.2.5affected
References
- https://github.com/vercel/next.js/security/advisories/GHSA-492v-c6pp-mqqv ↗
- https://access.redhat.com/security/cve/CVE-2026-44574 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2477207 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44574.json ↗
- https://access.redhat.com/errata/RHSA-2026:40974 ↗
- https://access.redhat.com/errata/RHSA-2026:37272 ↗
- https://access.redhat.com/errata/RHSA-2026:34608 ↗
- https://access.redhat.com/errata/RHSA-2026:54435 ↗