Description
The fix for CVE-2025-48913: Apache CXF: Untrusted JMS configuration can lead to RCE was not complete, meaning that another path in the code might lead to code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache CXF
Default version status: unaffected
4.2.0 to < 4.2.1affected4.0.0 to < 4.1.6affected0 to < 3.6.11affected
References
- https://lists.apache.org/thread/bqg6gjy2cx7rfyqjxcpv3jwjvmclvz4o ↗
- https://access.redhat.com/security/cve/CVE-2026-44417 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2480729 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44417.json ↗
- https://access.redhat.com/errata/RHSA-2026:37390 ↗