Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-43646

Apache Wicket: crafted URLs can bypass PackageResourceGuard

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Wicket

Default version status: unaffected

  • 8.0.0 to ≤ 8.17.0affected
  • 9.0.0 to ≤ 9.22.0affected
  • 10.0.0 to ≤ 10.8.0affected

References