Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-43515

Apache Tomcat: Security constraints not correctly applied

Description

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.21affected
  • 10.1.0-M1 to ≤ 10.1.54affected
  • 9.0.0.M1 to ≤ 9.0.117affected
  • 8.5.0 to ≤ 8.5.100affected
  • 7.0.0 to ≤ 7.0.109affected
  • 0 to < 7.0.0unknown

References