Skip to content
CVE PROGRAM SOURCE RECORD4.9 Medium

CVE-2026-42797

Apache Syncope: JexlContextBuilder Information Disclosure

Description

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Syncope

Default version status: unaffected

  • 3.0 to ≤ 3.0.16affected
  • 4.0 to ≤ 4.0.5affected
  • 4.1 to ≤ 4.1.0affected

References