Skip to content
CVE PROGRAM SOURCE RECORD7.2 High

CVE-2026-42782

Apache Syncope: Post-auth RCE via Groovy static

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Syncope

Default version status: unaffected

  • 3.0 to ≤ 3.0.16affected
  • 4.0 to ≤ 4.0.5affected
  • 4.1 to ≤ 4.1.0affected

References