Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-42354

Sentry: Improper authentication on SAML SSO process allows user identity linking

Description

Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

getsentry sentry

  • >= 21.12.0, < 26.4.1affected

References