Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2026-42268

ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

Description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

owasp-modsecurity ModSecurity

  • >= 3.0.0, < 3.0.15affected

References