Description
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
jupyterlab jupyterlab
>= 4.0.0, < 4.5.7affected
References
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4 ↗
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7 ↗
- https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html ↗
- https://jupyterlab.readthedocs.io/en/latest/user/extensions.html#extension-manager-implementations ↗
- https://access.redhat.com/security/cve/CVE-2026-42266 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2477072 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42266.json ↗
- https://access.redhat.com/errata/RHSA-2026:43038 ↗
- https://access.redhat.com/errata/RHSA-2026:60520 ↗