Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2026-41871

Apache Nutch: Unauthenticated reflection-based job execution in Nutch Server (Nutch REST API)

Description

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Nutch

Default version status: unaffected

  • 1.10 to ≤ 1.22affected

References