Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2026-41163

bubblewrap vulnerable to privilege escalation in setuid mode via ptrace

Description

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

containers bubblewrap

  • >= 0.11.0, < 0.11.2affected

References