Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2026-41043

Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues

Description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache ActiveMQ

Default version status: unaffected

  • 0 to < 5.19.6affected
  • 6.0.0 to < 6.2.5affected

Apache Software Foundation Apache ActiveMQ Web

Default version status: unaffected

  • 0 to < 5.19.6affected
  • 6.0.0 to < 6.2.5affected

References