Skip to content
CVE PROGRAM SOURCE RECORD5.8 Medium

CVE-2026-39998

Apache APISIX: Identity Injection via forward-auth Plugin Missing Header Cleanup

Description

Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache APISIX

Default version status: unaffected

  • 2.12.0 to ≤ 3.16.0affected

References