Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-34356

Apache HTTP Server: ProxyPassReverseCookieMap buffer overflow

Description

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie* This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache HTTP Server

Default version status: unaffected

  • 2.4.0 to ≤ 2.4.67affected

References