Description
A buffer overflow in mod_proxy_html in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend. Users are recommended to upgrade to version 2.4.68, which fixes this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache HTTP Server
Default version status: unaffected
2.4.0 to ≤ 2.4.67affected
References
- https://httpd.apache.org/security/vulnerabilities_24.html ↗
- http://www.openwall.com/lists/oss-security/2026/06/08/6 ↗
- https://access.redhat.com/security/cve/CVE-2026-34355 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2486414 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34355.json ↗
- https://access.redhat.com/errata/RHSA-2026:56868 ↗
- https://access.redhat.com/errata/RHSA-2026:47046 ↗
- https://access.redhat.com/errata/RHSA-2026:34109 ↗
- https://access.redhat.com/errata/RHSA-2026:42828 ↗
- https://access.redhat.com/errata/RHSA-2026:67152 ↗
- https://access.redhat.com/errata/RHSA-2026:66323 ↗
- https://access.redhat.com/errata/RHSA-2026:62165 ↗
- https://access.redhat.com/errata/RHSA-2026:41906 ↗
- https://access.redhat.com/errata/RHSA-2026:25042 ↗
- https://access.redhat.com/errata/RHSA-2026:53371 ↗
- https://access.redhat.com/errata/RHSA-2026:56869 ↗