Skip to content
CVE PROGRAM SOURCE RECORD7.4 High

CVE-2026-33804

@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Description

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

@fastify/middie @fastify/middie

Default version status: unaffected

  • 0 to < 9.3.2affected
  • 9.3.2unaffected
pkg:npm/@fastify/middie

References