Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-32990

Apache Tomcat: Fix for CVE-2025-66614 is incomplete

Description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.15 to ≤ 11.0.19affected
  • 10.1.50 to ≤ 10.1.52affected
  • 9.0.113 to ≤ 9.0.115affected

References