Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
craftcms cms
>= 4.0.0-RC1, < 4.17.5affected>= 5.0.0-RC1, < 5.9.11affected
References
- https://github.com/craftcms/cms/security/advisories/GHSA-4484-8v2f-5748 ↗
- https://github.com/craftcms/cms/security/advisories/GHSA-7jx7-3846-m7w7 ↗
- https://github.com/craftcms/cms/commit/78d181e12e0b15e1300f54ec85f19859d3300f70 ↗
- https://github.com/craftcms/cms/commit/dfec46362fcb40b330ce8a4d8136446e65085620 ↗