Skip to content
CVE PROGRAM SOURCE RECORD7.1 High

CVE-2026-30962

Parse Server has a protected fields bypass via logical query operators

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

parse-community parse-server

  • >= 9.0.0 < 9.5.2-alpha.6affected
  • < 8.6.19affected

References