Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2026-29170

Apache HTTP Server: mod_proxy_ftp XSS

Description

A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache HTTP Server

Default version status: unaffected

  • 0 to ≤ 2.4.67affected

References