Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-29146

Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.18affected
  • 10.0.0-M1 to ≤ 10.1.52affected
  • 9.0.13 to ≤ 9.0.115affected
  • 8.5.38 to ≤ 8.5.100affected
  • 7.0.100 to ≤ 7.0.109affected

References