Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-28814

Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering

Description

Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables. Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache JSPWiki

Default version status: unaffected

  • 0 to < 2.12.4affected

References