Skip to content
CVE PROGRAM SOURCE RECORD9.2 Critical

CVE-2026-27971

Qwik affected by unauthenticated RCE via server$ Deserialization

Description

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

QwikDev qwik

  • < 1.19.1affected

References