Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2026-24733

Apache Tomcat: Security constraint bypass with HTTP/0.9

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.14affected
  • 10.1.0-M1 to ≤ 10.1.49affected
  • 9.0.0.M1 to ≤ 9.0.112affected
  • 0 to ≤ 8.5.100affected

References