Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-24457

An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation co

Description

An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation could read unauthorized files of the OpenMQ’s host OS. In some scenarios RCE could be achieved. This is fixed in OpenMQ 6.5.2, 6.9.0, and in GlassFish 7.0.26, 7.1.1, and 8.0.2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Eclipse Foundation Eclipse OpenMQ

Default version status: unaffected

  • 0 to < 6.5.2affected
  • 6.6.0 to < 6.9.0affected

Eclipse Foundation Eclipse GlassFish

Default version status: unaffected

  • 0 to < 7.0.26affected
  • 7.1.0 to < 7.1.1affected
  • 8.0.0 to < 8.0.2affected

References