Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-23981

Apache Superset: Improper Authorization in Chart Update allowing Dashboard Modification

Description

An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to update charts to modify dashboards they do not own. When updating a chart's properties via the REST API, a user can provide a list of dashboard IDs (dashboards) to associate the chart with. The validation logic in the UpdateChartCommand failed to verify that the user had write permissions for the target dashboards specified in the request body. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 0.0.0 to < 6.0.0affected

References