Description
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
cakephp cakephp
>= 5.2.10, < 5.2.12affected>= 5.3.0, < 5.3.1affected
References
- https://github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5 ↗
- https://github.com/cakephp/cakephp/issues/19172 ↗
- https://github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f ↗
- https://bakery.cakephp.org/2026/01/14/cakephp_5212.html ↗
- https://github.com/cakephp/cakephp/releases/tag/5.2.12 ↗
- https://github.com/cakephp/cakephp/releases/tag/5.3.1 ↗