Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2026-2359

Multer vulnerable to Denial of Service via resource exhaustion

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

expressjs multer

Default version status: unaffected

  • 0.0.0 to < 2.1.0affected
pkg:npm/multer

References