Skip to content
CVE PROGRAM SOURCE RECORD8.5 High

CVE-2026-22610

Angular has XSS Vulnerability via Unsanitized SVG Script Attributes

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

angular angular

  • >= 21.1.0-next.0, < 21.1.0-rc.0affected
  • >= 21.0.0-next.0, < 21.0.7affected
  • >= 20.0.0-next.0, < 20.3.16affected
  • < 19.2.18affected

References