Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2026-2052

Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

Description

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets

Default version status: unaffected

  • 0 to ≤ 4.2.2affected

Marketing Fire, LLC Widget Options - Extended

Default version status: unaffected

  • 0 to ≤ 5.3.2affected

References