Skip to content
CVE PROGRAM SOURCE RECORD2.3 Low

CVE-2026-18816

Baserow 2FA Verify Endpoint views.py verify improper authentication

Description

A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

n/a Baserow

  • 2.3.0affected
  • 2.3.1affected
  • 2.3.2affected
  • 2.3.3unaffected

References