Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-18446

fast-uri vulnerable to host confusion via backslash authority introducer

Description

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

fast-uri fast-uri

Default version status: unaffected

  • 4.0.0 to < 4.1.2affected
  • 4.1.2unaffected
  • 3.0.0 to < 3.1.5affected
  • 3.1.5unaffected
  • 0 to < 2.4.4affected
  • 2.4.4unaffected
pkg:npm/fast-uri

References