Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-16221

fast-uri vulnerable to host confusion via literal backslash authority delimiter

Description

Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

fast-uri fast-uri

Default version status: unaffected

  • 2.3.1 to < 2.4.3affected
  • 2.4.3unaffected
  • 3.0.0 to < 3.1.4affected
  • 3.1.4unaffected
  • 4.0.0 to < 4.1.1affected
  • 4.1.1unaffected
pkg:npm/fast-uri

References