Description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Google Cloud Looker
Default version status: unaffected
0 to < 25.6.103affected0 to < 25.12.65affected0 to < 25.18.68affected0 to < 26.0.66affected0 to < 26.2.47affected0 to < 26.4.36affected0 to < 26.6.28affected0 to < 26.8.7affected
Google Cloud Looker
Default version status: unaffected
0 to < 25.6.103affected0 to < 25.12.65affected0 to < 25.18.68affected0 to < 26.0.66affected0 to < 26.2.47affected0 to < 26.4.36affected0 to < 26.6.28affected0 to < 26.8.7affected