Skip to content
CVE PROGRAM SOURCE RECORD6.8 Medium

CVE-2026-13769

Overly permissive File Permissions in AWS CLI

Description

Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register). To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

AWS AWS CLI

Default version status: unaffected

  • 0 to ≤ 1.44.77affected
  • 0 to ≤ 2.34.28affected

References