Skip to content
CVE PROGRAM SOURCE RECORD3.1 Low

CVE-2026-116687

CKEditor: Cross-site scripting (XSS) in the engine package

Description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

ckeditor ckeditor5

  • >= 29.0.0, < 47.7.4affected
  • >= 48.0.0, < 48.5.1affected

References