Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-11440

theonedev REST API default-branch improper authorization

Description

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

theonedev onedev

  • 15.0.0affected
  • 15.0.1affected
  • 15.0.2affected
  • 15.0.3affected
  • 15.0.4affected
  • 15.0.5affected
  • 15.0.6unaffected

References