Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2026-112105

GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation

Description

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GlitterWare Passy

  • 1.10.0affected
  • 1.10.1affected
  • 1.10.2unaffected

References