Description
A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a OpenSIPS
3.6.0affected3.6.1affected3.6.2affected3.6.3affected3.6.4affected3.6.5affected3.6.6affected3.6.7affected3.6.8affected4.0.0affected4.0.1affected3.6.9unaffected4.0.2unaffected
References
- https://vuldb.com/vuln/419834 ↗
- https://vuldb.com/vuln/419834/cti ↗
- https://vuldb.com/cve/CVE-2026-110679 ↗
- https://vuldb.com/submit/1003897 ↗
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qv9x-v8jq-434w ↗
- https://github.com/OpenSIPS/opensips/releases/tag/4.0.2 ↗
- https://github.com/OpenSIPS/opensips/ ↗