Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2026-103552

Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder

Description

Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Directory LDAP API

Default version status: unaffected

  • 1.2.0 to < 1.2.9affected
pkg:maven/org.apache.directory.api/api-ldap-codec-core

References