Description
A vulnerability was found in David-Crty databasement up to 1.7.1. This impacts the function https:/github.com/David-Crty/databasement/pull/511 of the file app/Http/Requests/Api/V1/RestoreRequest.php of the component database-servers API Endpoint. The manipulation of the argument schema_name results in path traversal. The attack may be launched remotely. A high complexity level is associated with this attack. The exploitability is said to be difficult. The exploit has been made public and could be used. Upgrading to version 1.7.2 will fix this issue. You should upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
David-Crty databasement
1.7.0affected1.7.1affected1.7.2unaffected
References
- https://vuldb.com/vuln/412345 ↗
- https://vuldb.com/vuln/412345/cti ↗
- https://vuldb.com/cve/CVE-2026-103533 ↗
- https://vuldb.com/submit/957817 ↗
- https://github.com/David-Crty/databasement/security/advisories/GHSA-x225-463f-pgww ↗
- https://github.com/David-Crty/databasement/pull/511 ↗
- https://github.com/David-Crty/databasement/releases/tag/v1.7.2 ↗
- https://github.com/David-Crty/databasement/ ↗